注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

北漂的小羊

Java编程,开发者,程序员,软件开发,编程,代码。新浪微博号:IT国子监

 
 
 

日志

 
 
关于我

在这里是面向程序员的高品质IT技术学习社区,是程序员学习成长的地方。让我们更好地用技术改变世界。请关注新浪微博号: IT国子监(http://weibo.com/itguozijian)

网易考拉推荐

digester异常:java.lang.UnsupportedOperationException: This parser does not support specification “null” version “null”解决方案  

2013-01-06 18:54:09|  分类: JAVA |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

异常说明:
在maven工程中使用的了digester,但报了如下一个错误: 
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl@65b60280:java.lang.UnsupportedOperationException: This parser does not support specification “null” version “null” 


解决方案:

Degister2.1和1.8都试过了,都不好使,网上说是很多情况下是因为sun和ibm的jaxp不同实现造成的,需要加jaxp.properties(javahome/jre/lib),还需要添加xerces-xxx.jar包。 

我试过了加了jar包也是不行的,甚至于造成eclipse也无法启动的现象。后来发现在classpath下有两个xerces的不同版本的包,一个是我手动加的xercesImpl.jar,一个是xercesImpl-2.6.2.jar,删除xercesImpl-2.6.2.jar后OK了! 


但这个xercesImpl-2.6.2.jar不是我主动引入的,一定是maven引用的其他的包依赖自动导入进来的。所以开始排查到底是那个包依赖了这个造成的。最后发现: 
<dependency> 
   <groupId>org.apache.cxf</groupId> 
   <artifactId>cxf-bundle-jaxrs</artifactId> 
   <version>2.2.5</version> 
</dependency> 
对xerces有依赖,所以增加exclusion即可: 
<exclusions> 
    <exclusion> 
         <groupId>xerces</groupId> 
    <artifactId>xercesImpl</artifactId> 
</exclusions> 


  评论这张
 
阅读(2698)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016