注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

北漂的小羊

Java编程,开发者,程序员,软件开发,编程,代码。新浪微博号:IT国子监

 
 
 

日志

 
 
关于我

在这里是面向程序员的高品质IT技术学习社区,是程序员学习成长的地方。让我们更好地用技术改变世界。请关注新浪微博号: IT国子监(http://weibo.com/itguozijian)

网易考拉推荐

异常Unable to validate using XSD: Your JAXP provider解决方案  

2012-11-28 17:50:23|  分类: spring |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

一、控制台异常信息:
严重: StandardWrapper.Throwable 
org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document 
from ServletContext resource [/WEB-INF/classes/application.xml]; nested exception is org.springframework 
.beans.factory.BeanDefinitionStoreException: Unable to validate using XSD: Your JAXP provider [gnu.xml.do 
m.JAXPFactory@f29441] does not support XML Schema. Are you running on Java 1.4 or below with Apache Crims 
on? Upgrade to Apache Xerces (or Java 1.5) for full XSD support. 
Caused by: org.springframework.beans.factory.BeanDefinitionStoreException: Unable to validate using XSD: 
Your JAXP provider [gnu.xml.dom.JAXPFactory@f29441] does not support XML Schema. Are you running on Java 
1.4 or below with Apache Crimson? Upgrade to Apache Xerces (or Java 1.5) for full XSD support. 
二、解决方案:
 在网上查了很多资料,说法不一,最后还是靠自己解决了。
思路一:jdk问题。
在MyEclipse中的Java Build Path中看到JRE System Library采用的是JDK1.6.0_20,而我拷贝到另一个workspace中的工程采用的是Myeclipse中的JRE,果断换成我电脑中的JDK,OK,问题搞定!!!
思路二:部署时junit的配置问题。
正式部署时又没有,查了些资料,最后在运行Junit的命令行中,加上了如下参数: 
-Djavax.xml.parsers.DocumentBuilderFactory=com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl -Djavax.xml.parsers.SAXParserFactory=com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl 
思路三:jar包问题。
jfreechart的jar文件 gnujaxp.jar 引起的问题,从项目中删除这个文件。

  评论这张
 
阅读(3055)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016