注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

北漂的小羊

Java编程,开发者,程序员,软件开发,编程,代码。新浪微博号:IT国子监

 
 
 

日志

 
 
关于我

在这里是面向程序员的高品质IT技术学习社区,是程序员学习成长的地方。让我们更好地用技术改变世界。请关注新浪微博号: IT国子监(http://weibo.com/itguozijian)

网易考拉推荐

myeclipse与axis2插件an error occured while completing process java.lang.reflect.invocationtargetex解决方案  

2012-11-30 17:43:20|  分类: eclipse |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

Eclipse中使用Axis2 code generator从wsdl生成代码发生错误:

一、直接把1.4插件中解压的文件夹:Axis2_Codegen_Wizard_1.3.0和Axis2_Service_Archiver_1.3.0放入:Genuitec\MyEclipse-8.6\dropins下


二、axis2-1.4插件使用中异常解决:

解决an error occured while completing process java.lang.reflect.invocationtargetex 
我在用axis2生成java代码的时候出现这个错误,用下面的方法解决了。

大家参考下吧


一、关闭MyEclipse-8.6

 

二、 拷贝axis2-1.4文件夹下面的lib目录下的"backport-util-concurrent-3.1.jar"和 "geronimo-stax-

api_1.0_spec-1.0.1.jar"到MyEclipse-8.6的安装目录下的"Genuitec\MyEclipse-8.6\dropins\Axis2_Codegen_Wizard_1.3.0\lib"

 

三、修改MyEclipse-8.6的安装目录下的

       1."Genuitec\MyEclipse-8.6\dropins\Axis2_Codegen_Wizard_1.3.0

    \plugin.xml" :

   添加
      <library name="lib/backport-util-concurrent-3.1.jar"> 
        <export name="*"/> 
      </library>

2.修改plugin.xml中的version  "1.3.0"改为 "1.4.0"

 

四、 进入."Genuitec\MyEclipse-8.6\dropins\将"Axis2_Codegen_Wizard_1.3.0" 文件夹改

为"Axis2_Codegen_Wizard_1.4.0". 

 

五、启动MyEclipse8.6 就OK了,第一次可能会报错但以后就不会了。


注意:复制"eronimo-stax-api_1.0_spec-1.0.1.jar"和"backport-util-concurrent-3.1.jar"文件,修改plugin.xml文件的过程需在将整个插件放入eclipse\plugins之前,也就是说先将需要的jar和修改的xml文件放入插件中,再将整个插件放入eclipse\plugins。 
直接把plugins目录下的axis2的包拷出来启动eclipse,关闭。 再拷贝进去,启动,就可以做到重新加载。

  评论这张
 
阅读(670)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016